Page loading problems
Incident Report for Big Cartel
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 09:44 MST
Monitoring
Our devs have mitigated the DoS attack so things should start getting back to normal but we'll continue to monitor the situation. So sorry again for the trouble!
Posted Nov 17, 2020 - 08:35 MST
Investigating
Our team is looking into a problem with Big Cartel store pages not loading. So sorry for the hassle! We'll provide updates here as soon as we learn more.
Posted Nov 17, 2020 - 08:27 MST
This incident affected: Storefront and Checkout.